old software bugs thread

Sep 4, 2011, 4:10 pm
Joined: Jan 11, 2008
Posts: 1,019
oh god I forgot how hilarious that was, i needed that

Sadly, in less hilarious buggery, I was able to send a PM to Z successfully but somehow his reply back was lost.
Sep 9, 2011, 3:41 am
Joined: Nov 22, 2008
Interests: IVAN
Posts: 1,163
The freelancers thread has an empty page 8.

Sep 9, 2011, 3:43 am
Ex-Tyrant of the IVANers


Joined: Dec 8, 2007
Occupation: Junior Scientist
Location: Not California
Interests: Physics and Astronomy, Exoplanets, Singing praise to Valpurus while smashing skulls with a bloody warhammer, Jogging
Posts: 2,912
Likely caused by a deleted post.
"Put more stuff in the... thing where... more stuff goes in."
Sep 9, 2011, 4:23 pm
Joined: Jan 11, 2008
Posts: 1,019
Very likely. Still, pretty buggy.
Sep 26, 2011, 11:23 pm
Joined: Dec 2, 2007
Location: New Attnam
Interests: bananas
Posts: 2,220
private messaging appears to be working? let me know if you guys experience any bugs with it
Oct 1, 2011, 8:29 am
Master mine stomper


Joined: Dec 16, 2007
Occupation: Shoveling. But metal.
Location: Blazing in the steppes
Interests: Absolutely fuck-all.
Posts: 2,049
This is weird... I keep clicking "remember me" as I log in, but I still have to log in again every time I visit. I'm using MacOS 10.6.8 and Chrome 14.0.835.186.

EDIT 3.10.2o11: I keep seeing an error message, that usually goes away by refreshing the forums. Today it didn't, for a while... I'm just saying, I don't know how old this gnoll is.

----
Warning: mysql_connect() [function.mysql-connect]: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2) in /home4/birdfeud/public_html/attnam/db.php on line 11
Unable to connect
----

As a side note, my doubts in macs are being backed up every day I start this machine.

EDIT: It happens almost every time I type "www.attnam.com/forum" for the first time on my wife's account after booting the computer. Using my bookmark on my own account seems to work. After I refresh the page, I'm logged out even if I check remember me. What else...
Oct 7, 2011, 3:54 am
Joined: Dec 3, 2007
Occupation: Chaos Weaver
Location: Standing between all life and death
Posts: 2,850
I get a similar error every day as well. I'll edit in the information when I see it tomorrow.

This is it:
You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'unique = unique+1 WHERE id = '26798'' at line 1

Also, browsing the shoutbox history doesn't seem to work. I can't look at other pages, just the latest one.

Okay, renaming thread titles also seem broken.

Fatal error: Call to undefined method stdClass::save() in /home4/birdfeud/public_html/attnam/posting.php on line 259
Uchuudonge wrote
creating stable chaos
making patterns where there should be none
sewing order into the chaos
you spit in the face of random numbers, of chaos
Oct 8, 2011, 3:01 am
Joined: Dec 3, 2007
Occupation: Chaos Weaver
Location: Standing between all life and death
Posts: 2,850
Deleting posts appear broken as well! Oh dear!

Column 'id' in where clause is ambiguous
Uchuudonge wrote
creating stable chaos
making patterns where there should be none
sewing order into the chaos
you spit in the face of random numbers, of chaos
Oct 11, 2011, 5:04 pm
Joined: Dec 2, 2007
Location: New Attnam
Interests: bananas
Posts: 2,220
Working on stuff whenever I can. One improvement I made was with Youtube embeds.... you used to have to get the video ID, but now you can use the video ID or URL. Also they're embedded with a larger size.
Oct 11, 2011, 6:57 pm
Joined: Dec 11, 2008
Posts: 1,770
That new thread you made (cutest thing ever) brought my browser to a grinding halt, then refused to play anything but the audio whilst the browser adamantly refused to let me do anything about it.

I point the rigid finger of accusation at the new youtube embed change

BUT i'll go try it again just in case.

EDIT: Upon reloading the page, the video worked as normal... up until the youtube player became unresponsive and kept on playing the video regardless of what I clicked.
Starting to think it could possibly be something on my end.
System would indicate in graphic if person is mounted on horse or not.
Same system also show if person mounted on boar, elephant, polar bear etc.
Or if person mounted on ass.
Ivan find mounting on ass funny.
Oct 11, 2011, 10:17 pm
Joined: Dec 2, 2007
Location: New Attnam
Interests: bananas
Posts: 2,220
Well it is using iframes, which are Youtube's preferred method of embedding video now, but are probably more intense for the browser to load.
Oct 18, 2011, 4:54 pm
Joined: Dec 11, 2008
Posts: 1,770
I'm posting within a window within a window!
(From pressing the "edit" button, no less.)
System would indicate in graphic if person is mounted on horse or not.
Same system also show if person mounted on boar, elephant, polar bear etc.
Or if person mounted on ass.
Ivan find mounting on ass funny.
Oct 18, 2011, 4:55 pm
Joined: Dec 11, 2008
Posts: 1,770
^Since I can't edit that^
Here's the picture which didn't upload.
System would indicate in graphic if person is mounted on horse or not.
Same system also show if person mounted on boar, elephant, polar bear etc.
Or if person mounted on ass.
Ivan find mounting on ass funny.
Oct 19, 2011, 3:21 pm
Master mine stomper


Joined: Dec 16, 2007
Occupation: Shoveling. But metal.
Location: Blazing in the steppes
Interests: Absolutely fuck-all.
Posts: 2,049
I can't access my personal messages...

Quote
Sorry, the page /messages/pmthread.php?p=866 does not exist
Oct 20, 2011, 5:05 am
Joined: Sep 22, 2008
Posts: 634
I'm being 404'd on all of my message threads as well, the error is the same as Erno has except for the thread numbers.
Oct 20, 2011, 5:19 am
Master mine stomper


Joined: Dec 16, 2007
Occupation: Shoveling. But metal.
Location: Blazing in the steppes
Interests: Absolutely fuck-all.
Posts: 2,049
Yeah, the thread number depends on the message. I tried about a third of them, none seems to work. Did you change the path or something?
Oct 20, 2011, 3:42 pm
Joined: Dec 2, 2007
Location: New Attnam
Interests: bananas
Posts: 2,220
Try again. There may be other similar errors where it links to a 404, please let me know if you find others.
Oct 20, 2011, 4:02 pm
Joined: Sep 22, 2008
Posts: 634
Seems functional now. Thanks!
Oct 21, 2011, 2:10 am
Master mine stomper


Joined: Dec 16, 2007
Occupation: Shoveling. But metal.
Location: Blazing in the steppes
Interests: Absolutely fuck-all.
Posts: 2,049
Yeah, fixed, thanks.
Oct 27, 2011, 3:24 am
Joined: Dec 3, 2007
Occupation: Chaos Weaver
Location: Standing between all life and death
Posts: 2,850
The search function and the advanced edit button seem to be broken.
Uchuudonge wrote
creating stable chaos
making patterns where there should be none
sewing order into the chaos
you spit in the face of random numbers, of chaos
Oct 27, 2011, 12:49 pm
Joined: Jan 11, 2008
Posts: 1,019
I think it's been mentioned before but when the first post on a new page of a thread is deleted, the new page remains, leaving a blank page.
Nov 5, 2011, 10:41 pm
Joined: Dec 2, 2007
Location: New Attnam
Interests: bananas
Posts: 2,220
Fixed the member list finally
Nov 6, 2011, 2:20 am
Joined: Dec 2, 2007
Location: New Attnam
Interests: bananas
Posts: 2,220
I fixed deleting of posts as well but the code is too different, I can't push it live yet. I'm hoping that by tomorrow I can upload some of the major changes...
Nov 8, 2011, 10:08 am
Joined: Sep 22, 2008
Posts: 634
Posting some screenshots of the buggedness.

Ubuntu 10.04 LTS with Firefox 3.6.23 for Ubuntu has some weird stuff going on with the header and menu bars on the top:


The bottom bar isn't showing correctly either:


The shoutbox bug, XP with Firefox 7.0.1:
Nov 8, 2011, 12:39 pm
Joined: Dec 4, 2007
Occupation: Perfect Soldier
Location: Astragius Galaxy
Interests: Fiana, Peace, Melons
Posts: 1,055
Shoutbox looks fine for me. Firefox 7.0.1, Windows XP. Looks like I'm in the minority.
Proudly bringing disaster and mental scarring to Attnam since '05!

"You have a rather pleasant chat about finite superarmpits with Sanae the shrine maiden."

You hear distant shuffling.

The Enner Beast tells you to COOL IT!!
Jump to