Cant use "dip" function, ! key seems mapped wrong?

May 16, 3:49 pm
#1
Joined: Mar 22, 2012
Posts: 12
Hi,

I was trying to play version 0.59 on windows 10. I'm using an azerty keyboard and trying the "dip" action gives me the "unknown key" message.
This happens when I use the Windows keyboard input method "English (United States) Belgian (period) Keyboard" setting and when I use the "French (Belgium) Belgian French Keyboard" setting.

Interestingly, on these types of keyboards, you have to press shift to type numbers with the keys right above the letter keys, if you use those without pressing shift you get all sorts of diacriticals, the &, (, etc... HOWEVER when I press the first ones without shift (the ones which on Querty keyboards would give you numbers 1, 2, 3, ...) I get "activate wizard mode..." messages... It seems like these keys are treated like Querty keys when shift isnt pressed and... Not sure how when shift is pressed. So something seems wrong about how those keys are interpreted by the game.

Is there some straightforward way in which I can fix this? Like can I configure this in some game file?

Thanks in advance!
May 17, 1:09 am
#2
Joined: Apr 2, 2014
Occupation: Navastating
Location: Aslona
Posts: 746
Hi,

IVAN reads the input character, not keyboard key, so you need to be typing "!" to use a dip command, no matter where on your keyboard that is. On QWERTY, that's Shift+1, but eg. on QWERTZ "!" is near the Enter key. On AZERTY, it seems that "!" should be next to the right Shift.

Or does that not work?
Jump to