Install Trouble with Windows - Microsoft Visual Studio 2017

Jan 31, 4:45 pm
#1
Joined: Jul 9, 2019
Occupation: Studio Art: sculpting major, and photography minor
Location: Cliping through the floor.
Interests: Photography, sculpting, games, anthropologie, the Copper Age to Medieval history, and Ivan. (Of course.)
Posts: 39
I know that I'm really a super novice with programming, but I've gotten stuck with Cmake cache after completing all the steps before opening the Ivan repository in Visual Studio 2019. Error below is what I get in the Cmake Output,


Quote
1> CMake generation started for configuration: 'x86-Release'.
1> The toolchain file has changed (CMAKE_TOOLCHAIN_FILE).
1> Command line: "cmd.exe" /c ""C:\PROGRAM FILES (X86)\MICROSOFT VISUAL STUDIO\2019\COMMUNITY\COMMON7\IDE\COMMONEXTENSIONS\MICROSOFT\CMAKE\CMake\bin\cmake.exe" -G "Visual Studio 15 2017" -A Win32 -DCMAKE_INSTALL_PREFIX:PATH="C:\Users\Alex\CMakeBuilds\f373c066-e80c-407c-980c-e8737aad3dde\install\x86-Release" -DCMAKE_TOOLCHAIN_FILE:STRING="C:/tools/vcpkg/scripts/buildsystems/vcpkg.cmake" -DHAVE_CXX14=ON, -DWIZARD=ON, -DMSVC_HIDE_CONSOLE_WINDOW=ON -DCMAKE_CONFIGURATION_TYPES="Release" "C:\Users\Alex\source\repos\ivan" 2>&1"
1> Working directory: C:\Users\Alex\CMakeBuilds\f373c066-e80c-407c-980c-e8737aad3dde\build\x86-Release
1> [CMake] CMake Error at C:\Users\Alex\source\repos\ivan\CMakeLists.txt:2 (project):
1> [CMake] Generator
1> [CMake]
1> [CMake] Visual Studio 15 2017
1> [CMake]
1> [CMake] could not find any instance of Visual Studio.
1> [CMake]
1> [CMake]
1> [CMake]
1> [CMake] -- Configuring incomplete, errors occurred!
1> [CMake] See also "C:/Users/Alex/CMakeBuilds/f373c066-e80c-407c-980c-e8737aad3dde/build/x86-Release/CMakeFiles/CMakeOutput.log".
1> [CMake]
1> cmd.exe /c ""C:\PROGRAM FILES (X86)\MICROSOFT VISUAL STUDIO\2019\COMMUNITY\COMMON7\IDE\COMMONEXTENSIONS\MICROSOFT\CMAKE\CMake\bin\cmake.exe" -G "Visual Studio 15 2017" -A Win32 -DCMAKE_INSTALL_PREFIX:PATH="C:\Users\Alex\CMakeBuilds\f373c066-e80c-407c-980c-e8737aad3dde\install\x86-Release" -DCMAKE_TOOLCHAIN_FILE:STRING="C:/tools/vcpkg/scripts/buildsystems/vcpkg.cmake" -DHAVE_CXX14=ON, -DWIZARD=ON, -DMSVC_HIDE_CONSOLE_WINDOW=ON -DCMAKE_CONFIGURATION_TYPES="Release" "C:\Users\Alex\source\repos\ivan" 2>&1" returned with exit code: 1
Feb 28, 1:23 pm
#2
Joined: Sep 8, 2010
Occupation: Petty Functionary
Location: Drinking pea soup in the world map
Interests: Mangoes
Posts: 1,176
In your local copy of CMakeSettings.json, try changing this line: https://github.com/Attnam/ivan/blob/913b9650edd0c9de4082c6ad...

To:
 "generator": "Visual Studio 16 2019",
Batman? wrote
its been so long since i had gotten that far i didnt think it through. arrrr!!!!!!
Mar 2, 10:46 am
#3
Joined: Jul 9, 2019
Occupation: Studio Art: sculpting major, and photography minor
Location: Cliping through the floor.
Interests: Photography, sculpting, games, anthropologie, the Copper Age to Medieval history, and Ivan. (Of course.)
Posts: 39
It works perfectly with that fix, thank you!
Mar 2, 4:02 pm
#4
Joined: Sep 8, 2010
Occupation: Petty Functionary
Location: Drinking pea soup in the world map
Interests: Mangoes
Posts: 1,176
TheMasterGear wrote
It works perfectly with that fix, thank you!

Thanks, I'm glad it worked. It's a rare thing, Sophos be praised.

I wonder whether multiple configurations can be supported in visual studio?
Batman? wrote
its been so long since i had gotten that far i didnt think it through. arrrr!!!!!!
Jump to