Error when launching IVAN 0.53-1

Jul 9, 5:31 pm
#1
giant mushroom


Joined: Jul 9, 2018
Posts: 2
I am using Manjaro linux 64bit with xfce.

I updated IVAN through AUR. I used to be able to run the last version.

I get the following error message when I try to launch IVAN from terminal:

ALSA lib seq_hw.c:466:(snd_seq_hw_open) open /dev/snd/seq failed: No such device

MidiOutAlsa::initialize: error creating ALSA sequencer client object.


MidiOutAlsa::initialize: error creating ALSA sequencer client object.

ivan(_ZN18globalerrorhandler22DumpStackTraceToStdErrEi+0x31)[0x56344e0305c1]
ivan(_ZN18globalerrorhandler5AbortEPKcz+0xa2)[0x56344e0307c2]
ivan(+0x345817)[0x56344de63817]
ivan(main+0x13a)[0x56344de6c48a]
/usr/lib/libc.so.6(__libc_start_main+0xeb)[0x7f7ceb1a306b]
ivan(_start+0x2a)[0x56344de6e9ba]
MIDI Out Error
Jul 9, 10:49 pm
#2
Joined: Sep 8, 2010
Occupation: Petty Functionary
Location: Drinking pea soup in the world map
Interests: Mangoes
Posts: 1,029
Have you got the ALSA sound device drivers and libraries available and installed on your linux distro?
Jul 10, 5:35 am
#3
giant mushroom


Joined: Jul 9, 2018
Posts: 2
Either reinstalling alsa-lib or rebooting fixed the problem.
Jul 10, 5:49 am
#4
Joined: Sep 8, 2010
Occupation: Petty Functionary
Location: Drinking pea soup in the world map
Interests: Mangoes
Posts: 1,029
Fandomethor wrote
Either reinstalling alsa-lib or rebooting fixed the problem.

Yay! Welcome to the forum by the way
Jump to