various rust bugs

Sep 18, 2010, 10:26 pm
#1
Joined: Dec 2, 2007
Location: New Attnam
Interests: bananas
Posts: 2,261
There seem to be 2 bugs with rust popping up in vasiliy's fork (probably common to LIVAN as well)

1) I changed the material of my helmet and my body armor. Neither one was rusty previously. when I change the material, it's fine, but when I take another step, they are suddenly "very rusted"
2) when I repair these very rusted items either with a smith or a scroll of repair, they are fine, but a few steps later they are suddenly very rusted again.

Sad, it's dropping my helmet AC from 33 to 20 and armor from 41 to 21
Sep 19, 2010, 4:53 am
#2
Joined: Sep 5, 2010
Posts: 103
hm. tnx. have to investigate this issue.

can you tell me what exactly i should do to reproduce this?
Sep 19, 2010, 1:35 pm
#3
Joined: Jan 11, 2008
Posts: 1,019
I'd imagine that it'd be easy to test in wizmode. Wish for a helmet, wish for an socm, use it to make the helmet something rather nice but rustable like steel or whatever it is cap is actually making stuff into, walk around a bit and see what happens. Then if that reproduces, wish for a scroll of repair and use that, then continue walking around.
Sep 19, 2010, 3:39 pm
#4
Joined: Dec 2, 2007
Location: New Attnam
Interests: bananas
Posts: 2,261
Part of me was covered in blood, which probably had something to do with it.

The helmet was a helm of brilliance - unicorn horn? The armor was the shirt of the Jaguar - phoenix feather I believe. Neither material is rustable but both had been covered in blood. When I changed them both into adamant, they both turned instantly rusty. So I think the game was keeping track of their rust, even though they were immune to it.
Sep 19, 2010, 9:37 pm
#5
Joined: Sep 5, 2010
Posts: 103
i am not sure, but i remember (i think) that there were some bug with resetting rust counter. and btw -- blood is like an acid: it eats alot of materials. those things was inherited from LIVAN.

but anyway -- i'll take a look at it. hope to fix it before 2487... sorry, 2256... sorry... 2132. ok, ok, 2058.
Sep 27, 2010, 4:26 am
#6
Joined: Sep 5, 2010
Posts: 103
sorry, i'm still can't reproduce the bug. i tried alot of times, but never got this bug. hope it just rusted and disappeared.
Jump to