official BUGS thread

http://attnam.com/topics/official-BUGS-thread


The Cathedral of Attnam > Website News

# Jan 24, 2015, 4:24 pm Hide

capristo

New software, new thread!

Please report any bugs in this thread. I will be tracking them here:
https://github.com/andrewtweber/parangi/issues

- shoutbox does not work... unfortunately only works without SSL
- links to single posts take you to the first page of the topic
- page needs to be refreshed to see unread posts
- registration does not save user fields
- sorting members list is broken
- "new private message" emails have no content
- topic & post counters aren't accurately updated when a post is deleted
- editing an album clears the "cover photo"
- mobile navigation menu isn't great
- quoting messages doesn't create quote bbcode
- stuff in code tags doesn't show up in topic review

Additionally there are some features that I haven't completed that I didn't view as essential. I'd rather have everybody on the new software and finish these things over time

- searching private messages
- searching forum - partially complete but some of the advanced features don't work
- previewing posts
- previewing private messages
- deleting a photo album

And finally, the theme. I know it's not great. I'm using Twitter Bootstrap on the front end and this was one of the themes available. My first priority is getting the theme cleaned up with the gold that we all love, and adding the icon back into the top left.
# Jan 24, 2015, 4:32 pm Hide

capristo

I just noticed the shoutbox is not playing nicely with SSL. That's a pity. I can't remove the SSL certificate because browsers will probably get stuck in a redirect loop since I was forcing SSL earlier. Working on this.
# Jan 24, 2015, 6:33 pm Hide

4zb4

Has the wiki simply vanished temporarily until things are working?
# Jan 24, 2015, 7:28 pm Hide

capristo

No that was unintentional because the new site is in a different directory. It's back up. Powered by completely different software so no need to take it down
# Jan 24, 2015, 8:23 pm Hide

Pent

Quick note that Jenny is no longer properly aligned in the top right corner.

Also the blink dog icon's background doesn't seem to be transparent, as you can see above.
# Jan 25, 2015, 2:34 am Hide

Pent

The automatic page resizing can get pretty messy:
# Jan 25, 2015, 10:08 pm Hide

chaostrom

"DuckDuck"?
# Jan 25, 2015, 10:41 pm Hide

Pent

chaostrom wrote
"DuckDuck"?

DuckDuckGo
# Jan 26, 2015, 4:39 am Hide

capristo

Does everyone like the full screen width? Or is it just too large on wider screens? Even on my laptop (~1300 px) it seems a little too wide
# Jan 26, 2015, 1:23 pm Hide

4zb4

We must go wider!

Yeah seems fine to me, it's not like there needs to be space for links or whatever around the sides.
# Jan 26, 2015, 10:12 pm Hide

Pent

I'm all for maximizing economy of screen space, so I think auto-resizing to fill the whole window is great.

I did notice, however, that I can't zoom in while on my phone, and there's a lot of dead space to the right on narrower screens/windows (both mobile and desktop).
# Jan 26, 2015, 11:10 pm Hide

capristo

Can you post a screenshot of the dead space? I'm not seeing it. Is it just on certain pages or all pages?

The disabled zoom is intentional... unfortunately for some devices like the iphone if you don't do that, when the user picks a text box or select box, it zooms the screen in which is annoying. If I can get rid of the dead space it shouldn't be a problem
# Jan 26, 2015, 11:20 pm Hide

capristo

Seems like new posts do not get detected until you refresh the page?
# Jan 26, 2015, 11:33 pm Hide

Pent

Here are a couple screenshots. Note that the narrower the window gets, the more space there is. On mobile there was quite a bit of blank space.

It only seems to happen on the forum threads, the rest of the pages act fine even if I make the window ridiculously narrow.
# Jan 26, 2015, 11:39 pm Hide

capristo

Ok cool I think it was just the large attachments. I set them to be a max width 100% and I think it's fixed.
# Jan 26, 2015, 11:42 pm Hide

Pent

Yeah, looks good; no more horizontal scroll bar.

One more minor issue I noticed with some of the narrower images in the Random Photo box:

# Feb 3, 2015, 3:20 pm Hide

Ernomouse

Is there a way to remove the MSN contact info in my profile?
# Feb 4, 2015, 12:51 am Hide

capristo

That is a missing feature. I removed it for you but I'll try to add that back in soon so that everyone else can manage theirs too
# Feb 4, 2015, 2:33 am Hide

JoKe

capristo wrote
Seems like new posts do not get detected until you refresh the page?
I keep seeing this as well. The new post indicator only lights up after you load the page a second time.
# Feb 8, 2015, 8:00 am Hide

chaostrom

So, I just tried to check out the latest post by Kamos. Clicked the "new post" button.

Took me to the start of the thread.
# Feb 11, 2015, 12:14 pm Hide

capristo

Thanks chaostrom, that bug should be fixed
# Feb 11, 2015, 12:33 pm Hide

capristo

JoKe wrote
I keep seeing this as well. The new post indicator only lights up after you load the page a second time.

I think this is fixed as well... will have to test to see
# Feb 13, 2015, 3:59 pm Hide

capristo

Fixed the bug where registration does not save profile fields.
# Mar 11, 2015, 5:47 am Hide

fejoa

Hi Cap, I can't sort the columns in the members list page.
# Mar 29, 2015, 7:20 pm Hide

capristo

Whoops, I messed something up with the quick edit divs. I'll fix that soon